本站首页    管理页面    写新日志    退出


«April 2019»
123456
78910111213
14151617181920
21222324252627
282930


公告

戒除浮躁,读好书,交益友


我的分类(专题)

日志更新

最新评论

留言板

链接

Blog信息
blog名称:邢红瑞的blog
日志总数:523
评论数量:1142
留言数量:0
访问次数:9243022
建立时间:2004年12月20日




[linux]64位RedHat下编译gnokii
原创空间,  文章收藏,  软件技术,  电脑与网络

邢红瑞 发表于 2010-8-20 16:56:39

 64位linux 发送短信,需要gnokii,找了一下rpm 最近的也是0.6.19,安装后 还需要libxpm.so晕倒。发现0.6.24就不是要了。只有自己编译了。出现checking for intltool >= 0.35.0... 0.31.2 foundconfigure: error: Your intltool is too old.  You need intltool 0.35.0 or later.解决办法如下:wget http://ftp.gnome.org/pub/gnome/sources/intltool/0.40/intltool-0.40.6.tar.gztar zxvf intltool-0.40.6.tar.gzcd intltool-0.40.6./configure make && make install然后编译 从http://www.gnokii.org/下载gnokii,并编译安装.[root@SAG]# tar jxvf gnokii-0.6.28.1.tar.bz2  [root@SAG]# cd gnokii-0.6.28 [root@SAG]# ./configure[root@SAG]# gmake[root@SAG]# gmake install[root@SAG]#cp /usr/local/share/doc/gnokii/sample/gnokiirc  /root/.gnokiirc[root@SAG]#vi ~/.gnokiirc echo -e "SMS-TEST FROM Lenovo" | gnokii --sendsms 1581XXXX自己做的安装脚本cp -f ./gnokii /usr/local/bin/chmod a+x /usr/local/bin/gnokiicp -f ./lib*  /usr/local/lib/cp -f ./.gnokiirc /root


阅读全文(4357) | 回复(0) | 编辑 | 精华
 



发表评论:
昵称:
密码:
主页:
标题:
验证码:  (不区分大小写,请仔细填写,输错需重写评论内容!)



站点首页 | 联系我们 | 博客注册 | 博客登陆

Sponsored By W3CHINA
W3CHINA Blog 0.8 Processed in 0.047 second(s), page refreshed 144254785 times.
《全国人大常委会关于维护互联网安全的决定》  《计算机信息网络国际联网安全保护管理办法》
苏ICP备05006046号